您的位置:首页 > 其它

(POJ - 3273)Monthly Expense

2017-08-13 16:55 246 查看

(POJ - 3273)Monthly Expense

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 28654 Accepted: 10923

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M

Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5

100

400

300

100

500

101

400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题目大意:将n个数组成的的序列,分成连续的m份区间,将每个区间的所有元素相加,得到m个和,这m个和中肯定有一个最大的,我们要使这个和最小。(最小化最大值

思路:我们可以知道这个值肯定在所有数中的最大值和所有数的和之间。那么我们只要在这个区间进行二分寻找符合题目要求的答案即可。

#include<cstdio>
using namespace std;

const int INF=0x3f3f3f3f;
const int maxn=100005;
int a[maxn];
int n,m;

bool check(int mid)
{
int cnt=1,sum=0;
for(int i=0;i<n;i++)
{
if(sum+a[i]<=mid) sum+=a[i];
else
{
cnt++;
sum=a[i];
}
}
if(cnt>m) return true;//答案偏小了
return false;
}

int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
int lo=-INF,hi=0,mid;
for(int i=0;i<n;i++)
{
scanf("%d",a+i);
hi+=a[i];
if(lo<a[i]) lo=a[i];
}
while(lo<=hi)
{
mid=(lo+hi)>>1;
if(check(mid)) lo=mid+1;
else hi=mid-1;
}
printf("%d\n",mid);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: