您的位置:首页 > 其它

hdu_1325 Is It A Tree?

2017-08-13 10:20 330 查看
Problem Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line
Case k is a tree." or the line
Case k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8 5 3 5 2 6 4

5 6 0 0

8 1 7 3 6 2 8 9 7 5

7 4 7 8 7 6 0 0

3 8 6 8 6 4

5 3 5 6 5 2 0 0

-1 -1

Sample Output

Case 1 is a tree.

Case 2 is a tree.

Case 3 is not a tree.

分析:

1、无环。

2、根节点入度为0, 其它为一。

3、只有一个根。

AC代码:

#include <iostream>
#include <stdio.h>

int father[100001];
int A[200002], T[200002];
//shu zu T ji lu ru du

int find(int x)// cha zhao
{
if(x != father[x])
{
father[x] = find(father[x]);
}
return father[x];
}

int Union(int x, int y)// he bing
{
int fx = find(x);
int fy = find(y);

if(fx == fy) return 0;
else father[fx] = fy;
return 1;
}

int main()
{
int a, b, num, ok, num1 = 0;
while(1)
{
ok = 1, num = 0; num1++;
while(scanf("%d %d", &a, &b))//shu ru shu ju
{
if(a < 0 || b < 0) return 0;
else if(a == 0 && b == 0) break;
A[++num] = a;
A[++num] = b;
}
for(int i = 1;i <= num;i++)//chu shi hua
{
father[A[i]] =A[i];
T[A[i]] = 0;
}

for(int i = 1; i <= num/2; i++)
{
if(ok)
{
if(Union(A[2*(i-1)+1], A[2*i]) == 0) ok = 0;
T[A[2*i]] ++;
}
}

if(ok == 1)
{
for(int i = 1;i<=num; i++)
{
if(find(father[A[i]]) != find(father[A[1]])) ok = 0;// pan huan
if(T[A[i]] > 1) ok =0;//pan duan ru du
}
if(ok==1)
printf("Case %d is a tree.\n",num1);
else
printf("Case %d is not a tree.\n",num1);
}
else
{
printf("Case %d is not a tree.\n",num1);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: