您的位置:首页 > 其它

POJ - 2349 Arctic Network(最小生成树)

2017-08-13 00:23 429 查看
题目链接:http://poj.org/problem?id=2349点击打开链接

Arctic Network

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 22033 Accepted: 6817
Description
The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing
the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 

Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers.
Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts. 

Input
The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number
of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000). 

Output
For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input
1
2 4
0 100
0 300
0 600
150 750


Sample Output
212.13


一开始想麻烦了 还拿出点单独考虑

其实卫星捷径-1就是少几条边

我们就能够贪心去掉最长边

#include<iostream>
#include<algorithm>
#include<string.h>
#include<cstdio>
4000

#include<queue>
#include<map>
#include<math.h>
#include<limits.h>
#include<vector>
#include <set>
#include <string>
using namespace std;
struct xjy
{
int x;
int y;
};
struct edge
{
int from;
int to;
double dis;
bool operator < (const edge &r) const
{
return dis>r.dis;
}
};
bool cmpmin(const edge &a,const edge &b)
{
return a.dis<b.dis;
};
bool cmpmax(const edge a,const edge b)
{
return a.dis>b.dis;
};
vector <xjy > point;
vector <edge> edgevector,mintree;
set<int > ss;
int pre[555];
int findx(int x)
{
int r=x;
while(r!=pre[r])
{
r=pre[r];
}
return r;
}
int main()
{
int n=0;
scanf("%d",&n);
while(n--)
{
point.clear();
edgevector.clear();
mintree.clear();
ss.clear();
for(int i=0;i<=510;i++)
{
pre[i]=i;
}
int s,p;
scanf("%d%d",&s,&p);
for(int i=0;i<p;i++)
{
xjy mid;
scanf("%d%d",&mid.x,&mid.y);
point.push_back(mid);
}
for(int i=0;i<point.size();i++)
{
for(int j=i+1;j<point.size();j++)
{
edge mid;
mid.from=i;
mid.to=j;
mid.dis=sqrt((point[i].x-point[j].x)*(point[i].x-point[j].x)+(point[i].y-point[j].y)*(point[i].y-point[j].y));
edgevector.push_back(mid);
}
}
sort(edgevector.begin(),edgevector.end(),cmpmin);
for(int i=0;i<edgevector.size();i++)
{
if(findx(edgevector[i].from)!=findx(edgevector[i].to))
{
mintree.push_back(edgevector[i]);
pre[findx(edgevector[i].from)]=findx(edgevector[i].to);
}
}
for(int i=0;i<=510;i++)
{
pre[i]=i;
}
sort(mintree.begin(),mintree.end(),cmpmax);
if(s>=mintree.size()+1)
printf("0.00\n");
else
{
printf("%.2f\n",mintree[s-1].dis);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: