您的位置:首页 > 其它

线段树的应用——hdu2795 Billboard

2017-08-12 19:14 295 查看
原题链接hdu2795

Billboard

Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24063 Accepted Submission(s): 9918


[align=left]Problem Description[/align] At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
[align=left]Input[/align] There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
[align=left]Output[/align] For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.
[align=left]Sample Input[/align]
3 5 5

2

4

3

3

3

[align=left]Sample Output[/align]
1

2

1

3

-1


题意:向一个大广告牌上贴小广告 每个小广告的宽度相同 优先向左上角贴

思路:用线段树维护每一段区间可以贴的广告长度的最大值

题目中数据量很大 但其实当h>n时 多余的高度是没用的 因为有n个广告的时候最多才会用到n个单位的宽度

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#define max_ 200010
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
struct node
{
int l,r,w;
};
struct node tree[max_*4];
int h,w,n,fi;
void built(int i,int l,int r)
{
tree[i].l=l;
tree[i].r=r;
tree[i].w=w;
if(l==r)
return;
int mid=(l+r)>>1;
built(i<<1,l,mid);
built(i<<1|1,mid+1,r);
}
void updata(int i,int x)
{
if(tree[i].l==tree[i].r)
{
tree[i].w-=x;
fi=tree[i].l;
return;
}
if(tree[i<<1].w>=x)
updata(i<<1,x);
else
updata(i<<1|1,x);
tree[i].w=max(tree[i<<1].w,tree[i<<1|1].w);
}
int main(int argc, char const *argv[])
{
while(scanf("%d%d%d",&h,&w,&n)!=EOF)
{
memset(tree,0,sizeof(tree));
int i;
if(h>n)
h=n;
built(1,1,h);
for(i=0;i<n;i++)
{
int x;
scanf("%d",&x);
if(x<=tree[1].w)
{
updata(1,x);
printf("%d\n",fi );
}
else
printf("-1\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: