您的位置:首页 > 其它

Power Strings poj2406 (kmp 进阶 next数组使用)

2017-08-12 15:04 267 查看
[align=center]Power Strings[/align]

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 46647 Accepted: 19516
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined
in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

#include <algorithm>
#include <iostream>
#include <cstring>
#include <iomanip>
#include <string>
#include <cstdio>
#include <cmath>
#include <map>

using namespace std;

#define For(i,a,b) for(i=a;i<=b;i++)
#define _For(i,a,b) for(i=b;i>=a;i--)
#define Out(x) cout<<x<<endl
#define Outdouble(x,a) cout<<fixed<<setprecision(a)<<1.0*x<<endl
#define pf printf
#define sf scanf
#define mset(arr,num) memset(arr,num,sizeof(arr))

#define ll long long
const ll inf = 550; ///
#define ok std::ios::sync_with_stdio(0)
#pragma comment(linker, "/STACK:102400000,102400000")

// #define debug
#if defined (debug)
---check---
#endif

/// ^_^  ^_^  ^_^  ^_^  ^_^  ^_^  ^_^  ^_^  ^_^  ^_^  ^_^  ^_^  ^_^ ///

int next[1000100];
string s;

void get_next()
{
int l = s.length();
int i=0,j=-1;
next[i] = j;
while(i < l)
{
if(j == -1||s[i]==s[j])
{
i++;
j++;
//next[i] = j;
if(s[i]!=s[j])
{
next[i] = j;
}
else
{
next[i]=next[j];
} ///better
}
else
{
j = next[j];
}
}
}

int main()
{
int i,num,n;
while(cin>>s)
{
if(s[0] == '.')
{
return 0;
}
int len = s.length();
get_next();
if(len%(len-next[len]) == 0)
{
cout<<len/(len-next[len])<<endl;
}
else
{
Out(1);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息