您的位置:首页 > 其它

【POJ 3264 Balanced Lineup】 线段树

2017-08-12 10:55 471 查看
Balanced Lineup

Time Limit: 5000MS Memory Limit: 65536K

Total Submissions: 55577 Accepted: 26052

Case Time Limit: 2000MS

Description

For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i

Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3

1

7

3

4

2

5

1 5

4 6

2 2

Sample Output

6

3

0

结构体记录 区间内的最大,最小值,建树 查询

AC代码:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 5e4 + 10;
const int INF = 0x3f3f3f3f;
typedef long long LL;
int N,Q,a[MAX];
struct node{ int x,y; }st[MAX * 4];
node init(int l,int r,int k){
if(l == r) return st[k] = node{a[l],a[l]};
int o = l + r >> 1;
node xx = init(l,o,k * 2),yy = init(o + 1,r,k * 2 + 1);
return st[k] = node{max(xx.x,yy.x),min(xx.y,yy.y)};
}
node qu(int L,int R,int l,int r,int k){
if(l > R || r < L) return node{-INF,INF};
if(l <= L && R <= r) return st[k];
else{
int o = L + R >> 1;
node xx = qu(L,o,l,r,k * 2) , yy = qu(o + 1,R,l,r,k * 2 + 1);
return node{max(xx.x,yy.x),min(xx.y,yy.y)};
}
}
int main()
{
while(~scanf("%d %d",&N,&Q)){
for(int i = 1; i <= N; i++)
scanf("%d",&a[i]);
int l,r; init(1,N,1);
while(Q--){
scanf("%d %d",&l,&r);
node o = qu(1,N,l,r,1);
printf("%d\n",o.x - o.y);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj