您的位置:首页 > 其它

UVA 10038 - Jolly Jumpers

2017-08-11 21:27 561 查看
A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n − 1. For instance,

1 4 2 3

is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.

Input

Each line of input contains an integer n ≤ 3000 followed by n integers representing the sequence.

Output

For each line of input, generate a line of output saying ‘Jolly’ or ‘Not jolly’.

Sample Input

4 1 4 2 3

5 1 4 2 -1 6

Sample Output

Jolly

Not jolly

题意:给定一个整数n,有一个长度为n的整数序列,如果这个序列相邻两个整数之间的差的绝对值均在1到n-1之间,并且这之间的每个数字都只出现一次,那么这个序列叫做Jolly Jumpers。

思路:首先把这n个数字存到数组或者栈中,每次两两比较这两个数,用一个数组记录出现的所有数字的次数;这个题目最重要的一步就是判断1到n-1出现的数字,如果两数字的绝对值差出现的次数大于一次或者其差不在1到n-1之间,那么可以判断不满足题意,否则,符合题意。

注意:需要注意的是,题目并没有告诉我们序列中数字的大小,所以使用int类型会出现runtime error的错误,需要使用long类型。

#include <cstdio>
#include <stack>
#include <memory.h>
#include <cstdlib>

using namespace std;

int main()
{
int cnt[3005];
int n;
while(~scanf("%d", &n)){
long a, b, k;
bool isJolly = true;
stack<long> num;
memset(cnt, 0, sizeof(int)*n);
k = n;
while(k--){
long x;
scanf("%ld", &x);
num.push(x);
}
for(int i = 1; i < n; i++){
a = num.top();
num.pop();
b = num.top();
long diff = labs(a-b);
cnt[diff]++;
if(cnt[diff] > 1 || diff < 1 || diff > n-1){
isJolly = false;
break;
}
}
if(isJolly)
printf("Jolly\n");
else
printf("Not jolly\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  uva