您的位置:首页 > 其它

HDU 3410 Passing the Message

2017-08-11 13:52 387 查看


Passing the Message

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 821    Accepted Submission(s): 542


Problem Description

What a sunny day! Let’s go picnic and have barbecue! Today, all kids in “Sun Flower” kindergarten are prepared to have an excursion. Before kicking off, teacher Liu tells them to stand in a row. Teacher Liu has an important message to announce, but she doesn’t
want to tell them directly. She just wants the message to spread among the kids by one telling another. As you know, kids may not retell the message exactly the same as what they was told, so teacher Liu wants to see how many versions of message will come
out at last. With the result, she can evaluate the communication skills of those kids.

Because all kids have different height, Teacher Liu set some message passing rules as below:

1.She tells the message to the tallest kid.

2.Every kid who gets the message must retell the message to his “left messenger” and “right messenger”.

3.A kid’s “left messenger” is the kid’s tallest “left follower”. 

4.A kid’s “left follower” is another kid who is on his left, shorter than him, and can be seen by him. Of course, a kid may have more than one “left follower”. 

5.When a kid looks left, he can only see as far as the nearest kid who is taller than him.

The definition of “right messenger” is similar to the definition of “left messenger” except all words “left” should be replaced by words “right”. 

For example, suppose the height of all kids in the row is 4, 1, 6, 3, 5, 2 (in left to right order). In this situation , teacher Liu tells the message to the 3rd kid, then the 3rd kid passes the message to the 1st kid who is his “left messenger” and the 5th
kid who is his “right messenger”, and then the 1st kid tells the 2nd kid as well as the 5th kid tells the 4th kid and the 6th kid. 

Your task is just to figure out the message passing route.

 

Input

The first line contains an integer T indicating the number of test cases, and then T test cases follows.

Each test case consists of two lines. The first line is an integer N (0< N <= 50000) which represents the number of kids. The second line lists the height of all kids, in left to right order. It is guaranteed that every kid’s height is unique and less than
2^31 – 1 .

 

Output

For each test case, print “Case t:” at first ( t is the case No. starting from 1 ). Then print N lines. The ith line contains two integers which indicate the position of the ith (i starts form 1 ) kid’s “left messenger” and “right messenger”. If a kid has no
“left messenger” or “right messenger”, print ‘0’ instead. (The position of the leftmost kid is 1, and the position of the rightmost kid is N)

 

Sample Input

2
5
5 2 4 3 1
5
2 1 4 3 5

 

Sample Output

Case 1:
0 3
0 0
2 4
0 5
0 0
Case 2:
0 2
0 0
1 4
0 03 0

 

题目大意:有n个人站成 一排,每个人都要找出他左边比他矮的人里面最高的人的位置,还要找到右边比他矮的人中最高的人的位置,注意他们不能越过比他们高的人去看后面的人,输出每个人左边比他矮的人里面最高的人的位置和右边比他矮的人中最高的人的位置。

一看就是单调栈了

#include<iostream>
#include<stack>
#include<cstring>
using namespace std;
int a[50010],l[50010],r[50010];
int main(){
int t;
cin>>t;
int kase=1;
while(t--){
stack<int> st;
int n;
cin>>n;
for(int i=1;i<=n;i++){
cin>>a[i];
}
memset(l,0,sizeof(l));
memset(r,0,sizeof(r));
for(int i=1;i<=n;i++){
while(!st.empty()&&a[st.top()]<a[i]){
int q=st.top();
st.pop();
if(!st.empty()) r[st.top()]=q;
}
st.push(i);
}
while(!st.empty()){
int q=st.top();
st.pop();
if(!st.empty()) r[st.top()]=q;
}
for(int i=n;i>=1;i--){
while(!st.empty()&&a[st.top()]<a[i]){
int q=st.top();
st.pop();
if(!st.empty()) l[st.top()]=q;
}
st.push(i);
}
while(!st.empty()){
int q=st.top();
st.pop();
if(!st.empty()) l[st.top()]=q;
}
cout<<"Case "<<kase++<<":"<<endl;
for(int i=1;i<=n;i++){
cout<<l[i]<<" "<<r[i]<<endl;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: