您的位置:首页 > 其它

2017多校联合第五场1001/hdu6085Rikka with Candies(bitset)

2017-08-11 12:34 225 查看


Rikka with Candies

Time Limit: 7000/3500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1389 Accepted Submission(s): 606



Problem Description

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

There are n children
and m kinds
of candies. The ith
child has Ai dollars
and the unit price of the ith
kind of candy is Bi.
The amount of each kind is infinity.

Each child has his favorite candy, so he will buy this kind of candies as much as possible and will not buy any candies of other kinds. For example, if this child has 10dollars
and the unit price of his favorite candy is 4 dollars,
then he will buy two candies and go home with 2 dollars
left.

Now Yuta has q queries,
each of them gives a number k.
For each query, Yuta wants to know the number of the pairs (i,j)(1≤i≤n,1≤j≤m) which
satisfies if the ith
child’s favorite candy is the jth
kind, he will take k dollars
home.

To reduce the difficulty, Rikka just need to calculate the answer modulo 2.

But It is still too difficult for Rikka. Can you help her?

Input

The first line contains a number t(1≤t≤5),
the number of the testcases.

For each testcase, the first line contains three numbers n,m,q(1≤n,m,q≤50000).

The second line contains n numbers Ai(1≤Ai≤50000) and
the third line contains m numbers Bi(1≤Bi≤50000).

Then the fourth line contains q numbers ki(0≤ki<maxBi) ,
which describes the queries.

It is guaranteed that Ai≠Aj,Bi≠Bj for
all i≠j.

Output

For each query, print a single line with a single 01 digit
-- the answer.

Sample Input

1
5 5 5
1 2 3 4 5
1 2 3 4 5
0 1 2 3 4


Sample Output

0
0
0
0
1


Source

2017 Multi-University Training Contest - Team 5

Recommend

liuyiding | We have carefully selected several similar problems for you: 6107 6106 6105 6104 6103

Statistic | Submit | Discuss | Note

题意:A数组n个数,B数组m个数,q个查询, 每次给出一个k,询问有多少对(i,j), 使得Ai % Bj = k, 输出对数对模2的值

题解:

考虑枚举k,此时只有bj>k,ai>=k,才可能满足ai%bj=k

bbi={i的>k的因子属于b[1...m]的个数}

此时余数为k的情况数=∑ni=1bbai−k

考虑用bitset存放a,bitsetA>>k等价于a数组全部元素减去k,丢弃<0的元素

bitsetBB[i]=bbi & 1

ans[k]=(bitsetA>>k) & bitsetBB.count() & 1

求解bb,对每个bi,枚举其倍数,O(N∑1bi)

最坏情况下变为N∗调和级数=O(N∑Ni=11N)约等于O(N∗ln(N+1))

枚举k,对bitsetA和bitsetBB进行and操作O(N232)

所以复杂度大概O(N232+N∗ln(N+1))
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <string.h>
#include <map>
#include <set>
#include <queue>
#include <deque>
#include <list>
#include <bitset>
#include <stack>
#include <stdlib.h>
#define lowbit(x) (x&-x)
#define e exp(1.0)
//ios::sync_with_stdio(false);
//    auto start = clock();
//    cout << (clock() - start) / (double)CLOCKS_PER_SEC;
typedef long long ll;
typedef long long LL;
using namespace std;
int read()
{
int res = 0, ch, flag = 0;

if((ch = getchar()) == '-')             //判断正负
flag = 1;

else if(ch >= '0' && ch <= '9')           //得到完整的数
res = ch - '0';
while((ch = getchar()) >= '0' && ch <= '9' )
res = res * 10 + ch - '0';

return flag ? -res : res;
}

const int maxn=50000+10;
bitset<maxn>a,b,ans;
bitset<maxn>bb;//b的倍数,bb[i]=1:有奇数个y满足i%b[y]==0
void solve(int maxk)
{
bb.reset();
ans.reset();
for(int i=maxk;i>=0;--i)//枚举k
{
ans[i]=(bb&(a>>i)).count()&1;
if(b[i])//枚举b[i]的倍数
for(int j=0;j<maxn;j+=i)
bb.flip(j);
}
}
int main()
{
ios::sync_with_stdio(false);
int T;
scanf("%d",&T);//cin>>T;
int n,m,q;
while(T--)
{
scanf("%d%d%d",&n,&m,&q);//cin>>n>>m>>q;
a.reset();
b.reset();
int maxk=0;
for(int i=0;i<n;i++)
{
int x;
scanf("%d",&x);//cin>>x;
a.set(x);
}
for(int i=0;i<m;i++)
{
int x;
scanf("%d",&x);//cin>>x;
b.set(x);
maxk=max(maxk,x);
}
solve(maxk);
while(q--)
{
int x;
scanf("%d",&x);//cin>>x;
if(ans[x])puts("1");//cout<<"1"<<endl;
else puts("0");//cout<<"0"<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  bitset 2017多校联合