您的位置:首页 > 其它

POJ3320-Jessica's Reading Problem

2017-08-11 11:31 323 查看

Jessica’s Reading Problem

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 13113 Accepted: 4508

Description

Jessica’s a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica’s text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica’s text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5

1 8 8 8 1

Sample Output

2

Source

POJ Monthly–2007.08.05, Jerry

题目大意:一本书有p页,每页有一个知识点ai,要覆盖所有知识点,最少要读连续多少页。

解题思路:尺取法

#include<iostream>
#include<cstdio>
#include<cmath>
#include<vector>
#include<algorithm>
#include<set>
#include<map>
#include<cstring>
using namespace std;
typedef long long LL;
const double eps=1e-8;
const int MAXN=1e6+5;
int a[MAXN];
set<int> all;
map<int,int> cnt;

int main()
{
int p;
while(scanf("%d",&p)!=EOF)
{
all.clear();
cnt.clear();
for(int i=0;i<p;++i)
{
scanf("%d",&a[i]);
all.insert(a[i]);
}
int n=all.size();
int s=0,t=0,num=0;
int res=p;
while(true)
{
while(t<p&&num<n)
{
//if(cnt[a[t++]]++==0) num++;
if(cnt[a[t]]==0)
{
num++;
}
cnt[a[t]]++;
t++;
}
if(num<n) break;
res=min(res,t-s);
//if(--cnt[a[s++]]==0) num--;
--cnt[a[s]];
if(cnt[a[s]]==0) --num;
s++;
}
printf("%d\n",res);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: