您的位置:首页 > 产品设计 > UI/UE

poj 1458 Common Subsequence 最长公共子序列 入门

2017-08-11 10:56 405 查看
Common Subsequence

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 54255 Accepted: 22551
Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1,
i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find
the length of the maximum-length common subsequence of X and Y.
Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc         abfcab
programming    contest
abcd           mnp

Sample Output
4
2
0

Source

Southeastern Europe 2003

解题思路:设输入的两个串为s1,s2,
设dp(i,j)表示::s1的左边i个字符形成的子串,与s2左边的j个字符形成的子串的最长公共子序列的长度(i,j从0
开始算)

c5a9

ac代码:

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <queue>
#include <set>
#define ll long long

using namespace std;
const int maxn=1005;
char s1[1005],s2[1005];

int dp[maxn][maxn];

int main(){

while(~scanf("%s%s",s1,s2)){

for(int i=0;i<=strlen(s1);i++){
dp[i][0]=0;
dp[0][i]=0;
}

for(int i=1;i<=strlen(s1);i++){
for(int j=1;j<=strlen(s2);j++){
if(s1[i-1] == s2[j-1]){
dp[i][j]=dp[i-1][j-1]+1;
}
else{
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
}
}
}
printf("%d\n",dp[strlen(s1)][strlen(s2)]);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: