您的位置:首页 > 其它

HDOJ1078 记忆化搜索入门题 有详细的记忆化搜索模板程序

2017-08-11 10:18 309 查看


FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10863    Accepted Submission(s): 4625


Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole.
Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run
at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks
of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

 

Input

There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 

The input ends with a pair of -1's. 

 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

 

Sample Output

37

 

Source

Zhejiang University Training Contest 2001

 

Recommend

We have carefully selected several similar problems for you:  1080 1074 1081 1025 1158 

从(0,0)这个点出发,每次最多走K步,要求走到的格子数大于原来的,求问总那么多步后总和最大是多少。

记忆化搜索,很多路径有重复的,跟DP有些相似。

写了个DFS的记忆化搜索模板,作为参考。

记忆化搜索是自顶向下的,用递归实现,返回的最优解应该在出发点上

#include <iostream>
#include <cstdio>
#include <cstring>
#include <ctime>
#include <algorithm>
#include <cmath>
using namespace std;

const int  maxn =105;
int a[maxn][maxn],dp[maxn][maxn];
int n,k;
int dx[]={0,0,1,-1};
int dy[]={1,-1,0,0};

int dfs(int x, int y){
int tmp=0;
for (int j=1;j<=k;j++){
for (int i=0;i<4;i++){
int xx=x+dx[i]*j; //k步是水平或竖直的
int yy=y+dy[i]*j;
if (xx<0 || yy<0 || xx>=n || yy>=n) continue;
if (a[x][y]>=a[xx][yy]) continue;
if (dp[xx][yy]) { //如果已经探索过了,就没必要继续深搜了
tmp=max(tmp,dp[xx][yy]); //取最大值
continue;
}
tmp=max(tmp,dfs(xx,yy)); //取所有方案中的最大值
}
}
return dp[x][y]=a[x][y]+tmp;
}

int main(){
std::ios::sync_with_stdio(false); //提高cin输入效率
while (cin >> n >> k){
if (n==-1 && k == -1) break;
for (int i=0;i<n;i++){
for (int j=0;j<n;j++) cin>>a[i][j];
}
memset(dp,0,sizeof(dp));
cout<<dfs(0,0)<<endl; //最优解在出发点上
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: