您的位置:首页 > 其它

最长公共子序列问题(LCS)

2017-08-11 09:10 387 查看
给出两个字符串A B,求A与B的最长公共子序列(子序列不要求是连续的)。

比如两个串为:

abcicba

abdkscab

ab是两个串的子序列,abc也是,abca也是,其中abca是这两个字符串最长的子序列。

输入

第1行:字符串A

第2行:字符串B

(A,B的长度 <= 1000)

输出

输出最长的子序列,如果有多个,随意输出1个。

输入示例

abcicba

abdkscab

输出示例

abca

解题思路:套用的LCS的模板。

#include<cstdio>
#include<cstring>
#include<stack>
#include<algorithm>
using namespace std;
int main()
{
char str1[1005];
char str2[1005];
scanf ("%s %s",str1+1,str2+1);
str1[0] = str2[0] = '0';
int l1 = strlen(str1)-1;
int l2 = strlen(str2)-1;
int dp[1005][1005] = {0};//0 i=0 || j=0

for (int i = 1 ; i <= l1 ; i++)
{
for (int j = 1 ; j <= l2 ; j++)
{
if (str1[i] == str2[j]) //dp[i-1][j-1]+1 str1[i]==str2[j]
dp[i][j] = dp[i-1][j-1] + 1;
else
dp[i][j] = max(dp[i-1][j],dp[i][j-1]); //max(dp[i-1][j],dp[i][j-1]) str1[i]!=str2[j]
}
}

//回溯求LCS
int pos1 = l1;
int pos2 = l2;
stack<char> S;
while (pos1 > 0 && pos2 > 0)
{
if (str1[pos1] == str2[pos2])
{
S.push(str1[pos1]);
pos1--;
pos2--;
}
else if (dp[pos1-1][pos2] > dp[pos1][pos2-1])
pos1--;
else
pos2--;
}
while (!S.empty())
{
printf ("%c",S.top());
S.pop();
}
// printf ("%d\n",dp[l1][l2]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: