您的位置:首页 > 其它

【HDU 6106 Classes】

2017-08-10 21:54 471 查看
Classes

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 237 Accepted Submission(s): 151

Problem Description

The school set up three elective courses, assuming that these courses are A, B, C. N classes of students enrolled in these courses.

Now the school wants to count the number of students who enrolled in at least one course in each class and records the maximum number of students.

Each class uploaded 7 data, the number of students enrolled in course A in the class, the number of students enrolled in course B, the number of students enrolled in course C, the number of students enrolled in course AB, the number of students enrolled in course BC, the number of students enrolled in course AC, the number of students enrolled in course ABC. The school can calculate the number of students in this class based on these 7 data.

However, due to statistical errors, some data are wrong and these data should be ignored.

Smart you must know how to write a program to find the maximum number of students.

Input

The first line of the input gives the number of test cases T; T test cases follow.

Each case begins with one line with one integer N, indicates the number of class.

Then N lines follow, each line contains 7 data: a, b, c, d, e, f, g, indicates the number of students enrolled in A, B, C, AB, BC, AC, ABC in this class.

It’s guaranteed that at least one data is right in each test case.

Limits

T≤100

1≤N≤100

0≤a,b,c,d,e,f,g≤100

Output

For each test case output one line contains one integer denotes the max number of students who enrolled in at least one course among N classes.

Sample Input

2

2

4 5 4 4 3 2 2

5 3 1 2 0 0 0

2

0 4 10 2 3 4 9

6 12 6 3 5 3 2

Sample Output

7

15

Hint

In the second test case, the data uploaded by Class 1 is wrong.

Because we can’t find a solution which satisfies the limitation.

As for Class 2, we can calculate the number of students who only enrolled in course A is 2,

the number of students who only enrolled in course B is 6, and nobody enrolled in course C,

the number of students who only enrolled in courses A and B is 1,

the number of students who only enrolled in courses B and C is 3,

the number of students who only enrolled in courses A and C is 1,

the number of students who enrolled in all courses is 2,

so the total number in Class 2 is 2 + 6 + 0 + 1 + 3 + 1 + 2 = 15.

Source

2017 Multi-University Training Contest - Team 6

题意: 给出选 A,B,C,AB,AC,BC,ABC 课程的学生,其中 AB 是 A 和 B 都选….,确定该班级的人数,给出的数据中有一些数错误的,但保证一组正确答案,输出最多的班级的人数

思路 : 根据 ABC 的人数,确定出只选 AB,BC,AC 的人数,进而在确定之选 A,B,C 的人数,若求出的 AB,BC,AC,A,B,C 都为非负数这合法,相加即为总人数

AC代码:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 1e5 + 10;
typedef long long LL;
int main()
{
int T,n;
scanf("%d",&T);
while(T--){
int ans = 0;
scanf("%d",&n);
int a,b,c,ab,bc,ac,abc;
for(int i = 1; i <= n; i++){
scanf("%d %d %d %d %d %d %d",&a,&b,&c,&ab,&bc,&ac,&abc);
ab -= abc, ac -= abc,bc -=abc;
if(ab < 0 || ac < 0 || bc < 0) continue;
int aa = a - ab - ac - abc;
int bb = b - ab - bc - abc;
int cc = c - ac - bc - abc;
if(aa < 0 || bb < 0 || cc < 0) continue;
int sum = aa + bb + cc + ab + bc + ac + abc;
ans = max(ans,sum);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: