您的位置:首页 > 大数据 > 人工智能

HDU - 6106 Classes (2017 Multi-University Training Contest - Team 6)

2017-08-10 18:49 483 查看


Classes

Problem Description

The school set up three elective courses, assuming that these courses are A, B, C. N classes of students enrolled in these courses.

Now the school wants to count the number of students who enrolled in at least one course in each class and records the maximum number of students.

Each class uploaded 7 data, the number of students enrolled in course A in the class, the number of students enrolled in course B, the number of students enrolled in course C, the number of students enrolled in course AB, the number of students enrolled in
course BC, the number of students enrolled in course AC, the number of students enrolled in course ABC. The school can calculate the number of students in this class based on these 7 data.

However, due to statistical errors, some data are wrong and these data should be ignored.

Smart you must know how to write a program to find the maximum number of students.

 

Input

The first line of the input gives the number of test cases T; T test cases follow.

Each case begins with one line with one integer N, indicates the number of class.

Then N lines follow, each line contains 7 data: a, b, c, d, e, f, g, indicates the number of students enrolled in A, B, C, AB, BC, AC, ABC in this class. 

It's guaranteed that at least one data is right in each test case.

Limits
T≤100
1≤N≤100
0≤a,b,c,d,e,f,g≤100

 

Output

For each test case output one line contains one integer denotes the max number of students who enrolled in at least one course among N classes.

 

Sample Input

2
2
4 5 4 4 3 2 2
5 3 1 2 0 0 0
2
0 4 10 2 3 4 9
6 12 6 3 5 3 2

 

Sample Output

7
15

Hint
In the second test case, the data uploaded by Class 1 is wrong.
Because we can't find a solution which satisfies the limitation.
As for Class 2, we can calculate the number of students who only enrolled in course A is 2,
the number of students who only enrolled in course B is 6, and nobody enrolled in course C,
the number of students who only enrolled in courses A and B is 1,
the number of students who only enrolled in courses B and C is 3,
the number of students who only enrolled in courses A and C is 1,
the number of students who enrolled in all courses is 2,
so the total number in Class 2 is 2 + 6 + 0 + 1 + 3 + 1 + 2 = 15.

 

题意:就是容斥……

解题思路:容斥……把每个区域都枚举出来,三个圆圈相交,可以形成七个区域,看看这七个区域有没有小于0的,有的话,证明数据错。

#include<iostream>
#include<memory.h>
#include<string>
#include<algorithm>
#include<math.h>
using namespace std;
int N;
int a[10];

int main(){

int t;
scanf("%d",&t);
while(t--){
scanf("%d",&N);

int maxsum=0;
for(int i=0;i<N;i++){
int A,B,C,AB,BC,AC,ABC;
scanf("%d%d%d%d%d%d%d",&A,&B,&C,&AB,&BC,&AC,&ABC);

a[1]=A-AC-AB+ABC;
a[3]=B-AB-BC+ABC;
a[7]=C-AC-BC+ABC;

a[2]=AB-ABC;
a[5]=AC-ABC;
a[6]=BC-ABC;

a[4]=ABC;

bool flag=true;
int sum=0;
for(int i=1;i<=7;i++){
sum+=a[i];
if(a[i]<0)
flag=false;
}

if(flag==false)
continue;

maxsum=max(maxsum,sum);

}

cout<<maxsum<<endl;

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐