您的位置:首页 > 其它

HDU 6106 (2017 多校训练赛6 1011)Classes

2017-08-10 17:29 447 查看

2017 Multi-University Training Contest - Team 6 1011


Classes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


Problem Description

The school set up three elective courses, assuming that these courses are A, B, C. N classes of students enrolled in these courses.

Now the school wants to count the number of students who enrolled in at least one course in each class and records the maximum number of students.

Each class uploaded 7 data, the number of students enrolled in course A in the class, the number of students enrolled in course B, the number of students enrolled in course C, the number of students enrolled in course AB, the number of students enrolled in
course BC, the number of students enrolled in course AC, the number of students enrolled in course ABC. The school can calculate the number of students in this class based on these 7 data.

However, due to statistical errors, some data are wrong and these data should be ignored.

Smart you must know how to write a program to find the maximum number of students.

 

Input

The first line of the input gives the number of test cases T; T test cases follow.

Each case begins with one line with one integer N, indicates the number of class.

Then N lines follow, each line contains 7 data: a, b, c, d, e, f, g, indicates the number of students enrolled in A, B, C, AB, BC, AC, ABC in this class. 

It's guaranteed that at least one data is right in each test case.

Limits
T≤100
1≤N≤100
0≤a,b,c,d,e,f,g≤100

 

Output

For each test case output one line contains one integer denotes the max number of students who enrolled in at least one course among N classes.

 

Sample Input

2
2
4 5 4 4 3 2 2
5 3 1 2 0 0 0
2
0 4 10 2 3 4 9
6 12 6 3 5 3 2

 

Sample Output

7
15

Hint
In the second test case, the data uploaded by Class 1 is wrong.
Because we can't find a solution which satisfies the limitation.
As for Class 2, we can calculate the number of students who only enrolled in course A is 2,
the number of students who only enrolled in course B is 6, and nobody enrolled in course C,
the number of students who only enrolled in courses A and B is 1,
the number of students who only enrolled in courses B and C is 3,
the number of students who only enrolled in courses A and C is 1,
the number of students who enrolled in all courses is 2,
so the total number in Class 2 is 2 + 6 + 0 + 1 + 3 + 1 + 2 = 15.

 

题意:
有n个班,每个班给出报名 A,B,C,AB,AC,BC,ABC 这些课程的人数,问至少报名一个课程的人有多少

分析:
找出那些数据是错误的,剩下的直接容斥输出最大的

AC代码:
#include <iostream>
#include <cstdio>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <algorithm>
#include <cstring>
#define LL long long

using namespace std;

int main()
{
int T;
scanf("%d", &T);
while(T--)
{
int n;
scanf("%d", &n);
int a, b, c, ab, bc, ac, abc;
int ans = 0;
for(int i = 0; i < n; i++)
{
scanf("%d%d%d%d%d%d%d",&a, &b, &c, &ab, &bc, &ac, &abc);
if(a-ab-ac+abc >= 0 && b-ab-bc+abc >=0 && c-ac-bc+abc >= 0 && ab <=min(a, b) && bc <= min(b, c) && ac <= min(a, c) && abc <= min(ab,min(bc,ac)))
ans = max(ans, a+b+c-ab-bc-ac+abc);
}
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: