您的位置:首页 > 其它

[HDU 1078 ] FatMouse and Cheese [ dp 记忆化搜索 ]

2017-08-10 16:16 465 查看
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.

The input ends with a pair of -1’s.

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1

1 2 5

10 11 6

12 12 7

-1 -1

Sample Output

37

代码

#include<bits/stdc++.h>
using namespace std;
const int MAXN =1e2+10;
int mp[MAXN][MAXN];
int dp[MAXN][MAXN];// dp[x][y] 表示从(x,y)坐标开始能够得到的最大数量
int n,k;
void getmap(){
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
scanf("%d",&mp[i][j]);
dp[i][j]=0;
}
}
}

int to[][2]={1,0,-1,0,0,1,0,-1};
int dfs(int x,int y){
if(dp[x][y]) return dp[x][y];  // 如果之前搜索过啦,就直接返回值
int val=0;
for(int i=1;i<=k;i++){
for(int j=0;j<4;j++){
int xx=x+i*to[j][0];
int yy=y+i*to[j][1];
if(xx<1||xx>n||yy<1||yy>n) continue;
if(mp[xx][yy]<=mp[x][y]) continue;
val=max(dfs(xx,yy),val);
}
}
return dp[x][y]=mp[x][y]+val;//返回的同时记录值
}

int main(){
while(~scanf("%d%d",&n,&k)){
if(n==k&&k==-1) break;
getmap();
dfs(1,1);
printf("%d\n",dp[1][1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: