您的位置:首页 > 大数据 > 人工智能

2017 Multi-University Training Contest - Team 6:1003&hdu6098、Inversion

2017-08-10 14:47 555 查看
题目:

[align=left]Problem Description[/align]
Give an array A, the index starts from 1.

Now we want to know Bi=maxi∤jAj
, i≥2.

 

[align=left]Input[/align]
The first line of the input gives the number of test cases T; T test cases follow.

Each case begins with one line with one integer n : the size of array A.

Next one line contains n integers, separated by space, ith number is
Ai.

Limits
T≤20
2≤n≤100000
1≤Ai≤1000000000
∑n≤700000
 

[align=left]Output[/align]
For each test case output one line contains n-1 integers, separated by space, ith number isBi+1.
 

[align=left]Sample Input[/align]

2
4
1 2 3 4
4
1 4 2 3

 

[align=left]Sample Output[/align]

3 4 3
2 4 4

题意:求出B_i+1数组,i从2开始,max{A_j}(i%j!=0)

思路:写个结构体,用x记录A的值,pos记录在A中的位置,排序,从大到小找符合条件的,输出。。。签到题

code:

#include<bits/stdc++.h>
using namespace std;
int a[100005];
struct node{
int x,pos;
}b[100005];
int cmp(node a,node b)
{
if(a.x<b.x) return 1;
return 0;
}
int main(){
int t,n,i,j;
scanf("%d",&t);
while(t--){
scanf("%d",&n);
for(i=1;i<=n;i++){
scanf("%d",&a[i]);
b[i].x=a[i];
b[i].pos=i;
}
sort(b+1,b+n+1,cmp);
for(i=2;i<=n;i++){
j=n;
while(b[j].pos%i==0) j--;
if(i!=n) printf("%d ",b[j].x);
else printf("%d\n",b[j].x);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  思维题
相关文章推荐