您的位置:首页 > 其它

Uva699 The Falling Leaves

2017-08-10 11:11 330 查看
题目链接:https://cn.vjudge.net/problem/UVA-699

Each year, fall in the North Central region is accompanied by the brilliant colors of the leaves on the trees, followed quickly by the falling leaves accumulating under the trees. If the same thing happened to binary trees, how large would the piles of leaves become?
We assume each node in a binary tree ”drops” a number of leaves equal to the integer value stored in that node. We also assume that these leaves drop vertically to the ground (thankfully, there’s no wind to blow them around). Finally, we assume that the nodes are positioned horizontally in such a manner that the left and right children of a node are exactly one unit to the left and one unit to the right, respectively, of their parent. Consider the following tree on the right:
The nodes containing 5 and 6 have the same horizontal position (with different vertical positions, of course). The node containing 7 is one unit to the left of those containing 5 and 6, and the node containing 3 is one unit to their right. When the ”leaves” drop from these nodes, three piles are created:
the leftmost one contains 7 leaves (from the leftmost node),
the next contains 11 (from the nodes containing 5 and 6), and
the rightmost pile contains 3. (While it is true that only leaf nodes in a tree would logically have leaves, we ignore that in this problem.)




Input

The input contains multiple test cases, each describing a single tree. A tree is specified by giving the

value in the root node, followed by the description of the left subtree, and then the description of the

right subtree. If a subtree is empty, the value ‘-1’ is supplied. Thus the tree shown above is specified

as ‘5 7 -1 6 -1 -1 3 -1 -1’. Each actual tree node contains a positive, non-zero value. The last test

case is followed by a single ‘-1’ (which would otherwise represent an empty tree).

Output

For each test case, display the case number (they are numbered sequentially, starting with 1) on a line

by itself. On the next line display the number of “leaves” in each pile, from left to right, with a single

space separating each value. This display must start in column 1, and will not exceed the width of an

80-character line. Follow the output for each case by a blank line. This format is illustrated in the

examples below.

Sample Input

5 7 -1 6 -1 -1 3 -1 -1

8 2 9 -1 -1 6 5 -1 -1 12 -1

-1 3 7 -1 -1 -1

-1

Sample Output

Case 1:

7 11 3

Case 2:

9 7 21 15

题意:二叉树落叶了。每个水平位置的落叶数是这个位置垂直方向上所有结点的值的和。如图:会落三堆树叶,第一堆有7片树叶,第二堆有5+6=11片树叶,第三堆有3片树叶。

给你按先序排好的二叉树(-1表示那个分支没有结点),从左到右输出每堆树叶的叶片数。

解题思路:既然已经给出了先序排列的序列了,就不用构造二叉树了,定义一个100的数组,从下标50开始向两边搜索,记录下每个下标对应的累加值,最后遍历输出。

AC代码:

#include<stdio.h>
#include<string.h>
using namespace std;

int sum[100];

void dfs(int v,int p)
{
if (v==-1) return ;

sum[p]+=v;//先累加这个树的根

int left,right;

scanf("%d",&left);
dfs(left,p-1);//向左找

scanf("%d",&right);
dfs(right,p+1);//向右找

return ;
}

int main ()
{
int v;
int q=1;
while(~scanf("%d",&v)&&v!=-1)//先输入的是每个树的根(根左右)
{

aeb2
int flag=0;
memset(sum,0,sizeof(sum));
dfs(v,50);//数组开100,从下标为50开始向两边搜
printf("Case %d:\n",q++);
for(int i=0;i<100;i++)
{
if(sum[i]!=0)
{
if(flag==0)
printf("%d",sum[i]);
else
printf(" %d",sum[i]);
flag=1;
}
}
printf("\n\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: