您的位置:首页 > 其它

HDU 6090 Rikka with Graph【思维题】

2017-08-09 21:57 363 查看


Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 679    Accepted Submission(s): 397


Problem Description

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

For an undirected graph G with n nodes
and m edges,
we can define the distance between (i,j) (dist(i,j))
as the length of the shortest path between i and j.
The length of a path is equal to the number of the edges on it. Specially, if there are no path between i and j,
we make dist(i,j) equal
to n.

Then, we can define the weight of the graph G (wG)
as ∑ni=1∑nj=1dist(i,j).

Now, Yuta has n nodes,
and he wants to choose no more than m pairs
of nodes (i,j)(i≠j) and
then link edges between each pair. In this way, he can get an undirected graph G with n nodes
and no more than m edges.

Yuta wants to know the minimal value of wG.

It is too difficult for Rikka. Can you help her?  

In the sample, Yuta can choose (1,2),(1,4),(2,4),(2,3),(3,4).

 

Input

The first line contains a number t(1≤t≤10),
the number of the testcases. 

For each testcase, the first line contains two numbers n,m(1≤n≤106,1≤m≤1012).

 

Output

For each testcase, print a single line with a single number -- the answer.

 

Sample Input

1
4 5

 

Sample Output

14

 

Source

2017 Multi-University Training Contest - Team 5



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <string>
#include <map>
#include <cstring>
#define INF 0x3f3f3f3f
#define ms(x,y) memset(x,y,sizeof(x))
using namespace std;

typedef long long ll;
typedef unsigned long long ull;
typedef pair<int, int> P;

const int maxn = 30010;
const int mod = 998244353;

#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

int main()
{
std::ios::sync_with_stdio(false);
int t;
cin >> t;
while (t--)
{
ll n, m, ans = 0;
cin >> n >> m;
if (m <= n - 1)
{
ll p = m + 1, q = n - p; //p连接的点,q孤立的点
ans = (2 * p - 2)*(p - 1) + q*(q - 1)*n + 2 * p*q*n;
}
else if (m <= (n - 1)*n / 2)
{
m = (n - 1)*n / 2 - m;
ans = n*(n - 1);
ans += 2 * m;
}
else
{
ans = n*(n - 1);
}
cout << ans << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: