您的位置:首页 > 其它

Matrix (POJ - 2155 )(树状数组的区间更新-点查询)

2017-08-09 21:21 447 查看
Matrix

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 28962 Accepted: 10572
Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change
it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 

2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output
1
0
0
1

Source

POJ Monthly,Lou Tiancheng

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
int map_[2000][2000];
int n,m;
int low_bit(int x)
{
return x&(-x);
}
void add(int x,int y,int w)
{
while(x<=n)
{
int temp=y;
while(temp<=n)
{
map_[x][temp]+=w;
temp+=low_bit(temp);
}
x+=low_bit(x);
}
}
int  ans(int x,int y)
{
int ans_=0;
while(x>0)
{
int temp=y;
while(temp>0)
{
ans_+=map_[x][temp];
temp-=low_bit(temp);
}
x-=low_bit(x);
}
return ans_;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
memset(map_,0,sizeof(map_));
for(int i=0;i<m;i++)
{
char c;
int x1,y1,x2,y2;
scanf(" %c",&c);
if(c=='C')
{
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
add(x1,y1,1);
add(x1,y2+1,-1);
add(x2+1,y1,-1);
add(x2+1,y2+1,1);
}
else
{
int x,y;
scanf("%d%d",&x,&y);
printf("%d\n",ans(x,y)%2);
}
}
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  树状数组