您的位置:首页 > 产品设计 > UI/UE

HDU-1159-Common Subsequence

2017-08-09 20:10 381 查看
点击打开链接


Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 40701    Accepted Submission(s): 18783


Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2,
..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length
common subsequence of X and Y. 

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line. 

 

Sample Input

abcfbc abfcab
programming contest
abcd mnp

 

Sample Output

4
2
0

题解:最基础的 LIS 求最长公共子序列 。这种基础题直接套模板就行了

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[10024][10024]={0};
int main()
{
char str1[10024],str2[10024];
while(~scanf("%s%s",str1+1,str2+1)) //从第一开始存的,所以加1了
{
int l1,l2;

str1[0]='0';
str2[0]='0';
l1=strlen(str1)-1; //从一开始存的,字符串长度也-1
l2=strlen(str2)-1;
for(int i=1;i<=l1;i++)
for(int j=1;j<=l2;j++)
{
if(str1[i]==str2[j])
dp[i][j]=dp[i-1][j-1]+1;
else
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
}
printf("%d\n",dp
4000
[l1][l2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: