您的位置:首页 > 其它

HDU-1069-Monkey and Banana

2017-08-09 19:59 337 查看
点击打开链接


Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 16010    Accepted Submission(s): 8495


Problem Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana
by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

 

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.

 

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

 

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

 

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题解:一块砖头有6中摆放形式,都要考虑

#include<stdio.h>
#include<algorithm>
using namespace std;

int k;

struct Stick{ //结构体记录砖的数据
int x,y,z;
}stick[200];

bool cmp(Stick a,Stick b)
{
if(a.x==b.x)
return a.y>b.y;
return a.x>b.x;
}

void solve(int a,int b,int c) //一块砖的6种放置方式
{
stick[k].x=a;
stick[k].y=b;
stick[k++].z=c;

stick[k].x=a;
stick[k].y=c;
stick[k++].z=b;

stick[k].x=b;
stick[k].y=a;
stick[k++].z=c;

stick[k].x=b;
stick[k].y=c;
stick[k++].z=a;

stick[k].x=c;
stick[k].y=b;
stick[k++].z=a;

stick[k].x=c;
stick[k].y=a;
stick[k++].z=b;
}
int main()
{
int n,x,y,z;
int dp[200]; //dp[i]表示摞i块能达到的最大高度
int Case=1;
while(~scanf("%d",&n),n)
{
int ans=0;
k=1;
for(int i=1;i<=n;i++)
{
scanf("%d%d%d",&x,&y,&z);
solve(x,y,z);
}
k--;
sort(stick+1,stick+k+1,cmp); //按长或宽从大到小排序
for(int i=1;i<=k;i++) //stick[i]表示新加上的砖块
{
dp[i]=stick[i].z;
//如果新加上的砖块长和宽都比上一块小,那么就能够摞上去
for(int j=1;j<i;j++)
if(stick[i].x<stick[j].x&&stick[i].y<stick[j].y)
dp[i]=max(dp[i],dp[j]+stick[i].z); //找到磊i块能达到的最大高度

ans=max(ans,dp[i]); //找到 最大值
}

printf("Case %d: maximum height = %d\n",Case++,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: