您的位置:首页 > 其它

【PAT】【Advanced Level】1058. A+B in Hogwarts (20)

2017-08-09 19:15 471 查看


1058. A+B in Hogwarts (20)

时间限制

50 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to
compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27

Sample Output:
14.1.28


原题链接:

https://www.patest.cn/contests/pat-a-practise/1058

https://www.nowcoder.com/pat/5/problem/4111

思路:

相加、取余数、进位

CODE:

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
int a1,b1,c1;
scanf("%d.%d.%d",&a1,&b1,&c1);
int a2,b2,c2;
scanf("%d.%d.%d",&a2,&b2,&c2);
int a3,b3,c3;
c3=(c1+c2)%29;
b3=(b1+b2+(c1+c2)/29)%17;
a3=a1+a2+(b1+b2+(c1+c2)/29)/17;
cout<<a3<<"."<<b3<<"."<<c3;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: