您的位置:首页 > 编程语言 > C语言/C++

HDU1020(水题)

2017-08-09 17:47 211 查看
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

 

[align=left]Input[/align]
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

 

[align=left]Output[/align]
For each test case, output the encoded string in a line.

 

[align=left]Sample Input[/align]

2
ABC
ABBCCC

 

[align=left]Sample Output[/align]

ABC
A2B3C

 

 

//看错题目,WA了几次,ORZ

 

[cpp]
view plain
copy

print?

#include <iostream>  
#include <cstdio>  
#include <cstring>  
using namespace std;  
  
int main()  
{  
    int n,i,cnt;  
    char str[10005];  
    cin >> n;  
    while(n--)  
    {  
        cin >> str;  
        for(i = 0; str[i]!='\0';)  
        {  
            cnt = 1;  
            while(str[i] == str[i+1])  
            {  
                cnt++;  
                i++;  
            }  
            if(cnt == 1)  
            cout << str[i];  
            else  
            cout << cnt << str[i];  
            i++;  
        }  
        cout << endl;  
    }  
  
    return 0;  
}  

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int main()
{
int n,i,cnt;
char str[10005];
cin >> n;
while(n--)
{
cin >> str;
for(i = 0; str[i]!='\0';)
{
cnt = 1;
while(str[i] == str[i+1])
{
cnt++;
i++;
}
if(cnt == 1)
cout << str[i];
else
cout << cnt << str[i];
i++;
}
cout << endl;
}

return 0;
}


 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm c语言 HDU 水题