您的位置:首页 > 其它

Uva839 Not so Mobile(天平)

2017-08-09 17:05 585 查看
链接:https://cn.vjudge.net/problem/UVA-839

Before being an ubiquous communications gadget, a mobile was just a structure made of strings and wires suspending colourfull things. This kind of mobile is usually found hanging over cradles of small babies.

The figure illustrates a simple mobile. It is just a wire, suspended by a string, with an object on each side. It can also be seen as a kind of lever with the fulcrum on the point where the string ties the wire. From the lever principle we know that to balance a simple mobile the product of the weight of the objects by their distance to the fulcrum must be equal. That is Wl × Dl = Wr × Dr where Dl is the left distance, Dr is the right distance, Wl is the left weight and Wr is the right weight.

In a more complex mobile the object may be replaced by a sub-mobile, as shown in the next figure. In this case it is not so straightforward to check if the mobile is balanced so we need you to write a program that, given a description of a mobile as input, checks whether the mobile is in equilibrium or not.



Input

The input begins with a single positive integer on a line by itself indicating the number

of the cases following, each of them as described below. This line is followed by a blank

line, and there is also a blank line between two consecutive inputs.

The input is composed of several lines, each containing 4 integers separated by a single space.

The 4 integers represent the distances of each object to the fulcrum and their weights, in the format:

Wl Dl Wr Dr

If Wl or Wr is zero then there is a sub-mobile hanging from that end and the following lines define

the the sub-mobile. In this case we compute the weight of the sub-mobile as the sum of weights of

all its objects, disregarding the weight of the wires and strings. If both Wl and Wr are zero then the

following lines define two sub-mobiles: first the left then the right one.

Output

For each test case, the output must follow the description below. The outputs of two

consecutive cases will be separated by a blank line.

Write ‘YES’ if the mobile is in equilibrium, write ‘NO’ otherwise.

Sample Input

1

0 2 0 4

0 3 0 1

1 1 1 1

2 4 4 2

1 6 3 2

Sample Output

YES

题意:给出t,表示t组数据

接下来按先序输入一棵树

每一行是wl,dl,wr,dr。根据平衡公式wl*dl==wr*dr判断这一整个天平是否平衡

是输出YES否则NO

0表示这一端没有砝码而是连接着一个小天平

解题思路:递归构造树,所有小天平平衡即所有子树平衡则整体平衡。

注意输出格式:除最后一组输出 都要多输出一个换行

(烧脑的递归。。)

AC代码:

#include<stdio.h>

int flag;

int build()
{
int wl,dl,wr,dr;
scanf("%d%d%d%d",&wl,&dl,&wr,&dr);
if(wl==0) wl=build();//如果有左子树
if(wr==0) wr=build();//如果有右子树(如果都没有子树就直接下一步判断了)
if(wl*dl!=wr*dr) flag=0;
return wl+wr;//大天平一端的W是小天平两边的W总和
}

int main()
{
int t;
scanf("%d",&t);
while(t--)
{
flag=1;
build();
if(flag) printf("YES\n");
else printf("NO\n");
if(t) printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: