您的位置:首页 > 其它

HDU-KazaQ's Socks

2017-08-09 16:22 106 查看

KazaQ’s Socks

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1344 Accepted Submission(s): 786

Problem Description

KazaQ wears socks everyday.

At the beginning, he has n pairs of socks numbered from 1 to n in his closets.

Every morning, he puts on a pair of socks which has the smallest number in the closets.

Every evening, he puts this pair of socks in the basket. If there are n−1 pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the k-th day.

Input

The input consists of multiple test cases. (about 2000)

For each case, there is a line contains two numbers n,k (2≤n≤109,1≤k≤1018).

Output

For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

Sample Input

3 7
3 6
4 9


Sample Output

Case #1: 3
Case #2: 1
Case #3: 2


#include<iostream>
#include<cstdio>
using namespace std;

int main()
{                               ///惨痛教训:
long long int n,k,m,sum=1;///类型一定要用“long long”,不然会wa掉;
while(~scanf("%lld %lld",&n,&k))
{
m=k-n;
if(k<=n)
{
printf("Case #%lld: %lld\n",sum++,k);
continue;
}
if(m%(n-1)==0)
{
if(m/(n-1)%2==0)
printf("Case #%lld: %lld\n",sum++,n);
else
printf("Case #%lld: %lld\n",sum++,n-1);
}
else
printf("Case #%lld: %lld\n",sum++,m%(n-1));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: