您的位置:首页 > 其它

2017多校联合第五场1006/hdu6090Rikka with Graph(思维公式)

2017-08-09 16:07 375 查看


Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 592    Accepted Submission(s): 353


Problem Description

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

For an undirected graph G with n nodes
and m edges,
we can define the distance between (i,j) (dist(i,j))
as the length of the shortest path between i and j.
The length of a path is equal to the number of the edges on it. Specially, if there are no path between i and j,
we make dist(i,j) equal
to n.

Then, we can define the weight of the graph G (wG)
as ∑ni=1∑nj=1dist(i,j).

Now, Yuta has n nodes,
and he wants to choose no more than m pairs
of nodes (i,j)(i≠j) and
then link edges between each pair. In this way, he can get an undirected graph G with n nodes
and no more than m edges.

Yuta wants to know the minimal value of wG.

It is too difficult for Rikka. Can you help her?  

In the sample, Yuta can choose (1,2),(1,4),(2,4),(2,3),(3,4).

 

Input

The first line contains a number t(1≤t≤10),
the number of the testcases. 

For each testcase, the first line contains two numbers n,m(1≤n≤106,1≤m≤1012).

 

Output

For each testcase, print a single line with a single number -- the answer.

 

Sample Input

1
4 5

 

Sample Output

14

 

Source

2017 Multi-University Training Contest - Team 5

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6095 6094 6093 6092 6091 

 

Statistic | Submit | Discuss | Note
给你一个n和m,让你用这m条边将n个点链接起来,使得对于全部的pair<i,j>的最短路之和最小。没有路的值就为n。

考虑贪心地一条一条边添加进去。

当 m
\leq n-1m≤n−1 时,我们需要最小化距离为 nn 的点对数,所以肯定是连出一个大小为 m+1m+1 的联通块,剩下的点都是孤立点。在这个联通块中,为了最小化内部的距离和,肯定是连成一个菊花的形状,即一个点和剩下所有点直接相邻。

当 m
> n-1m>n−1 时,肯定先用最开始 n-1n−1 条边连成一个菊花,这时任意两点之间距离的最大值是 22。因此剩下的每一条边唯一的作用就是将一对点的距离缩减为 11。

这样我们就能知道了最终图的形状了,稍加计算就能得到答案。要注意 mm 有可能大于 \frac{n(n-1)}{2}​2​​n(n−1)​​
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
long long i,j,k,p,t;
long long n,m;
long long tot;
cin>>t;
while(t--)
{
cin>>n>>m;
tot=0;
if(m>=n*(n-1)/2)
{
for(i=1;i<=n-1;i++)
tot+=i;
cout<<tot*2<<endl;
}
else if(m>=n-1)
{
for(i=1;i<=n-1;i++)
tot+=i*2;
tot-=m;
cout<<tot*2<<endl;
}
else
{
for(i=1;i<=m;i++)
tot+=i*2;
tot-=m;
for(i=m+1;i<=n-1;i++)
tot+=i*n;
cout<<tot*2<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  2017多校联合