您的位置:首页 > 其它

2017多校联合第五场1011/hdu6095Rikka with Competition(排序)

2017-08-09 16:02 344 查看


Rikka with Competition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 396    Accepted Submission(s): 328


Problem Description

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

A wrestling match will be held tomorrow. n players
will take part in it. The ith
player’s strength point is ai.

If there is a match between the ith
player plays and the jth
player, the result will be related to |ai−aj|.
If |ai−aj|>K,
the player with the higher strength point will win. Otherwise each player will have a chance to win.

The competition rules is a little strange. Each time, the referee will choose two players from all remaining players randomly and hold a match between them. The loser will be be eliminated. After n−1 matches,
the last player will be the winner.

Now, Yuta shows the numbers n,K and
the array a and
he wants to know how many players have a chance to win the competition.

It is too difficult for Rikka. Can you help her?  

 

Input

The first line contains a number t(1≤t≤100),
the number of the testcases. And there are no more than 2 testcases
with n>1000.

For each testcase, the first line contains two numbers n,K(1≤n≤105,0≤K<109).

The second line contains n numbers ai(1≤ai≤109).

 

Output

For each testcase, print a single line with a single number -- the answer.

 

Sample Input

2
5 3
1 5 9 6 3
5 2
1 5 9 6 3

 

Sample Output

5
1

 

Source

2017 Multi-University Training Contest - Team 5

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6095 6094 6093 6092 6091 

 

Statistic | Submit | Discuss | Note

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
int i,j,k,p,t;
int n;
int a[100001];
int tot;
cin>>t;
while(t--)
{
cin>>n>>k;
tot=1;
for(i=1;i<=n;i++)
{
cin>>a[i];
}
sort(a+1,a+n+1);
for(i=n-1;i>=1;i--)
{
if(a[i+1]-a[i]<=k)tot++;
else break;
}
cout<<tot<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  2017多校联合