您的位置:首页 > 其它

hdu 5036 Explosion(bitset处理概率)

2017-08-09 13:59 344 查看


Explosion

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 1247    Accepted Submission(s): 453


Problem Description

Everyone knows Matt enjoys playing games very much. Now, he is playing such a game. There are N rooms, each with one door. There are some keys(could be none) in each room corresponding to some doors among these N doors. Every key can open only one door. Matt
has some bombs, each of which can destroy a door. He will uniformly choose a door that can not be opened with the keys in his hand to destroy when there are no doors that can be opened with keys in his hand. Now, he wants to ask you, what is the expected number
of bombs he will use to open or destroy all the doors. Rooms are numbered from 1 to N.

 

Input

The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow.

In the first line of each test case, there is an integer N (N<=1000) indicating the number of rooms. 

The following N lines corresponde to the rooms from 1 to N. Each line begins with an integer k (0<=k<=N) indicating the number of keys behind the door. Then k integers follow corresponding to the rooms these keys can open.

 

Output

For each test case, output one line "Case #x: y", where x is the case number (starting from 1), y is the answer which should be rounded to 5 decimal places.

 

Sample Input

2
3
1 2
1 3
1 1
3
0
0
0

 

Sample Output

Case #1: 1.00000
Case #2: 3.00000

 

一扇门最多由一个炸弹炸开,如果一扇门中有另一扇门的钥匙,那么这扇门对炸弹的贡献变小

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <map>
#include <queue>
#include <bitset>
using namespace std;
typedef long long LL;
const int N = 50;
bitset<1005>q[10005],tmp;

int main()
{
int ncase=1, n, t, x, y;
scanf("%d", &t);
while(t--)
{
scanf("%d", &n);
for(int i=0;i<n;i++)
{
q[i].reset();
q[i][i]=1;
scanf("%d", &x);
while(x--)
{
scanf("%d", &y),y--;
q[i][y]=1;
}
}
double ans=0;
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
if(q[j][i]==1)
{
q[j]|=q[i];
}
}
}
for(int i=0;i<n;i++)
{
double cnt=0;
for(int j=0;j<n;j++)
{
if(q[j][i]==1) cnt++;
}
ans+=1.0/cnt;
}
printf("Case #%d: %.5f\n",ncase++,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: