您的位置:首页 > 其它

POJ-3628--Bookshelf 2--01背包

2017-08-09 10:38 477 查看
Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal ‘excess’ height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B

* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16

3

1

3

5

6

Sample Output

1

题意:已知书架的高度B,和N个木凳的高度,问怎样组合才能使木凳的高度减去书架的高度最小。

遍历dp数组,找到比B大的就跳出。

#include<iostream>
using namespace std;
const int M=1e6+10;
int dp[M+50],v[M+50],w[M+50];
int main()
{
int n,b;
cin>>n>>b;
int i,j;
for(i=1;i<=n;i++)
cin>>v[i];
for(i=1;i<=n;i++)
{
for(j=M;j>=v[i];j--)
{
dp[j]=max(dp[j-v[i]]+v[i],dp[j]);
}
}
int ans=0;
for(i=1;i<=M;i++)
{
if(dp[i]>=b)
{
ans=dp[i];//找到比b大的值就跳出
break;
}
}
cout<<ans-b<<endl;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: