您的位置:首页 > 其它

HDU - 1024 Max Sum Plus Plus(DP)

2017-08-09 10:09 441 查看
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^


Input

Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 … S n.

Process to the end of file.

Output

Output the maximal summation described above in one line.

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3


Sample Output

6
8


Hint

Huge input, scanf and dynamic programming is recommended.


题解参考http://blog.sina.com.cn/s/blog_677a3eb30100jxqa.html

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#define N 1000100
#define INF 0x3f3f3f3f
using namespace std;
long long dp[2]
;
long long a
;
int main()
{
int n, m;
while(scanf("%d%d", &m, &n) != EOF)
{
memset(dp, 0, sizeof(dp));
for(int i = 1; i <= n; i++)
{
scanf("%lld", &a[i]);
}
for(int i = 1; i <= m; i++)
{
dp[i % 2][i] = dp[(i + 1)% 2][i- 1] + a[i];
long long int _max = dp[(i + 1) % 2][i - 1];
for(int j = i + 1; j <= n; j++)
{
_max = max(_max, dp[(i + 1) % 2][j - 1]);
dp[i % 2][j] = max(dp[i % 2][j - 1], _max) + a[j];
}
}
long long int _max = -INF;
int index = m % 2;
for(int i = m; i <= n; i++)
{
_max = max(_max, dp[index][i]);
}
printf("%lld\n", _max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dp