您的位置:首页 > 产品设计 > UI/UE

【POJ2533】Longest Ordered Subsequence (动态规划&最长上升子序列)

2017-08-09 00:52 483 查看
这里是题目

Longest Ordered Subsequence

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 54195 Accepted: 24230

Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7

1 7 3 5 9 4 8

Sample Output

4

#include<stdio.h>
#include<math.h>
int s[1010],a[1010];
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
int m,n;
while(~scanf("%d",&n))
{
int sum=0,temp;
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
s[0]=1;
for(int i=1;i<n;i++)
{
temp=0;
for(int j=0;j<i;j++)
{
if(a[i]>a[j])
if(temp<s[j])
temp=s[j];
}
s[i]=temp+1;
}
int max=0;
for(int i=0;i<n;i++)
{
if(max<s[i])
max=s[i];
}
printf("%d\n",max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  动态规划 poj