您的位置:首页 > 其它

How Many Equations Can You Find

2017-08-08 20:22 369 查看
How Many Equations Can You Find

Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer
N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.

InputEach case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.
OutputThe output contains one line for each data set : the number of ways you can find to make the equation.
Sample Input
123456789 3
21 1


Sample Output
18
1


#include <cstdio>
#include <cstring>
const int MAX=1e7;
char str[MAX];
int n,len,cut;
void dfs(int l,__int64 sum)
{
if(l == len&& sum == n)
{
cut++;
return ;
}
__int64 ans=0;
for(int i= l;i < len ;i++)
{
ans=ans*10+(str[i]-'0');
dfs(i+1,sum+ans);
if(l)
dfs(i+1,sum-ans);
}
}
int main()
{
while(~scanf("%s %d",str,&n))
{
cut=0;
len=strlen(str);
dfs(0,0);
printf("%d\n",cut);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: