您的位置:首页 > 其它

HDU 【1087】Super Jumping! Jumping! Jumping

2017-08-08 20:20 337 查看
[align=left]Problem Description[/align]
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In
the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping
can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his
jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.

Your task is to output the maximum value according to the given chessmen list.

 

[align=left]Input[/align]
Input contains multiple test cases. Each test case is described in a line as follow:

N value_1 value_2 …value_N

It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.

A test case starting with 0 terminates the input and this test case is not to be processed.

 

[align=left]Output[/align]
For each case, print the maximum according to rules, and one line one case.

 

[align=left]Sample Input[/align]

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

 

[align=left]Sample Output[/align]

4
10
3

 

[align=left]Author[/align]
lcy

代码如下 代码有解释 其实到现在都不是很理解动态规划的思想,慢慢做题再说吧

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
int n;
while(scanf("%d",&n)!=EOF&&n)
{
int dp[1005];
int w[1005];
int max;//用来储存最大上升子序列和
for(int i=0;i<n;i++)
scanf("%d",&w[i]);
dp[0]=w[0];//dp[i]表示以第i个数为终点的序列最大和
max=dp[0];
for(int i=1;i<n;i++)
{
dp[i]=w[i];//先把终点确定
for(int j=0;j<i;j++)
{
if(w[i]>w[j]&&dp[j]+w[i]>dp[i])//判断前i个数的子序列最大和是否发生改变,是的话更新
{
dp[i]=dp[j]+w[i];
}
}
}
for(int i=0;i<n;i++)
{
if(dp[i]>max)
{
max=dp[i];
}
}
printf("%d\n",max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: