您的位置:首页 > 产品设计 > UI/UE

[POJ - 2533] Longest Ordered Subsequence(动态规划)

2017-08-08 20:09 423 查看
Link:http://poj.org/problem?id=2533

Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8


Sample Output

4


题解:

求最长上升子序列个数

和 HDU-1257 代码几乎一样


http://blog.csdn.net/JomoDimple_/article/details/76921220

Code:

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int a[1010];
int dp[1010];
int main()
{
int n;
while(~scanf("%d",&n))
{
int i,j,ans=0;
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
dp[i]=1;
for(j=0;j<i;j++)
if(a[j]<a[i])
dp[i]=max(dp[i],dp[j]+1);
ans=max(ans,dp[i]);
}
printf("%d\n",ans);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: