您的位置:首页 > 其它

poj 2352 Stars (树状数组)

2017-08-08 19:37 323 查看
Stars

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 48298 Accepted: 20847
Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know
the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars
are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5

Sample Output
1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
Source

Ural Collegiate Programming Contest 1999

思路:题目的输入数据已经按照y的升序排好了,于是每次输入进去x时,都可以计算在它前面有多少个星星,那么这就是它的等级。

注意题目数据有0,所以更新数状数组的时候用x+1就可以解决了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX_N 32005
int n,tree[MAX_N],sum[MAX_N],stars[MAX_N],x,y;
using namespace std;
int Lowbit(int i)
{
return i&(-i);
}
void update(int i,int x)
{
while(i<=MAX_N)
{
tree[i]=tree[i]+x;
i=i+Lowbit(i);
}
}
int query(int n)
{
int sum=0;
while(n>0)
{
sum+=tree
;
n=n-Lowbit(n);
}
return sum;
}
int main()
{
while(~scanf("%d",&n))
{
memset(sum,0,sizeof(sum));
memset(tree,0,sizeof(tree));
memset(stars,0,sizeof(stars));
for(int i=1;i<=n;i++)
{
scanf("%d%d",&x,&y);
update(x+1,1);
int cnt=query(x+1)-1;
stars[cnt]++;
}
for(int i=0;i<n;i++)
printf("%d\n",stars[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: