您的位置:首页 > 其它

【HDU 1114】Piggy-Bank(dp||完全背包问题)

2017-08-08 18:16 531 查看
点击打开题目

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 26458    Accepted Submission(s): 13391


[align=left]Problem Description[/align]
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has
any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay
everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility
is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank
that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

 

[align=left]Input[/align]
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled
with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency.
Follo
4000
wing this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

 

[align=left]Output[/align]
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total
weight. If the weight cannot be reached exactly, print a line "This is impossible.".

 

[align=left]Sample Input[/align]

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

 

[align=left]Sample Output[/align]

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

 

[align=left]Source[/align]
Central Europe 1999 

题意:完全背包的变形 , 改成背包问题的描述就是 , 求出把背包装满可以获得的最小的价值 .

题解:

完全背包思路:给出状态转移方程:dp[j]=min(dp[j],dp[j-money[i].weigt]+money[i].value)//表示重量为j的时候的获得的最小价值

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#define INF 0x3f3f3f3f
using namespace std;
const int MAX=1e6+10;

int dp[MAX];

struct Money{
int weigt;
int value;
}money[MAX];

int main(){
int T;
cin>>T;
while(T--){
int st_w,en_w;
cin>>st_w>>en_w;
int weight=en_w-st_w;
int kind;
cin>>kind;
memset(dp,INF,sizeof(dp));//求最小应初始化最大
dp[0]=0;

for(int i=0;i<kind;i++){
cin>>money[i].value>>money[i].weigt;
}

for(int i=0;i<kind;i++){
for(int j=money[i].weigt;j<=weight;j++){
dp[j]=min(dp[j],dp[j-money[i].weigt]+money[i].value);
}
}

if(dp[weight]!=INF)
cout<<"The minimum amount of money in the piggy-bank is "<<dp[weight]<<"."<<endl;
else
cout<<"This is impossible."<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: