您的位置:首页 > 其它

POJ 3159 Candies (差分约束 Dijkstra+优先队列 SPFA+栈)

2017-08-08 15:22 489 查看
During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers
of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies
fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another
bag of candies from the head-teacher, what was the largest difference he could make out of it?

 

Input

<p>The input contains a single test cases. The test cases starts with a line with two integers <i>N</i> and <i>M</i> not exceeding 30 000 and 150 000 respectively. <i>N</i> is the number of kids in the class and the kids were numbered 1 through <i>N</i>. snoopy
and flymouse were always numbered 1 and <i>N</i>. Then follow <i>M</i> lines each holding three integers <i>A</i>, <i>B</i> and <i>c</i> in order, meaning that kid <i>A</i> believed that kid <i>B</i> should never get over <i>c</i> candies more than he did.</p>

 

Output

<p>Output one line with only the largest difference desired. The difference is guaranteed to be finite.</p>

 

Sample Input

2 2
1 2 5
2 1 4

 

Sample Output

5题意:班长发糖果,班里面有不良风气,A希望B的糖果不比自己多C个。要满足所有人的要求,并求出最后一个人最多比第一个人多多少个糖果


这是属于差分约束的内容,刚开始我进入了理解误区,一直认为这个最大是9个,忽略了其他的限制条件。可以使用Dijkstra +优先队列(堆heap)http://blog.csdn.net/hrn1216/article/details/51465270
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
using namespace std;

struct Node
{
int k;
int w;
};

bool operator < (const Node &a,const Node &b)
{
return a.w > b.w;
}

priority_queue <Node> pq;
bool bUsed[30010]={0};
vector<vector<Node> > v; //定义一个不定长度的二维数组

int main()
{
int n,m,a,b,c;
int i,j,k;
Node p;
scanf("%d%d",&n,&m);
v.clear();
v.resize(n+1);
memset(bUsed,0,sizeof(bUsed));
for (i=1;i<=m;i++)
{
scanf("%d%d%d",&a,&b,&c);
p.k=b;
p.w=c;
v[a].push_back(p);
}
p.k=1;
p.w=0;
pq.push(p);
while(!pq.empty())
{
p=pq.top();
pq.pop();
if (bUsed[p.k]) continue;  //找到最短路径
bUsed[p.k]=true;
if (p.k==n) break;  //找到n的最短路径
for (i=0,j=v[p.k].size();i<j;i++)  //寻找最短路径
{
Node q;
q.k=v[p.k][i].k;
if (bUsed[q.k]) continue;
q.w=p.w+v[p.k][i].w;
pq.push(q);
}
}
printf("%d",p.w);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  图论 最短路径