您的位置:首页 > 产品设计 > UI/UE

Hdu1159-Common Subsequence-【LCS】

2017-08-08 10:45 323 查看
题目地址:acm.hdu.edu.cn/showproblem.php?pid=1159

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 40613    Accepted Submission(s): 18739


[align=left]Problem Description[/align]
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing
sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of
the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line.

 

[align=left]Sample Input[/align]

abcfbc abfcab
programming contest
abcd mnp

 

[align=left]Sample Output[/align]

4
2
0

 

[align=left]Source[/align]
Southeastern Europe 2003
 

[align=left]Recommend[/align]
Ignatius   |   We have carefully selected several similar problems for you:  1087 1176 1003 1058 1069 

0123456
yiBDCABA
0xi0000000
1A0000111
2B0111122
3C0112222
4B0112233
5D0122233
6A0122334
7B0122344


在画上图的时候碰到了一些问题,自己总结成两条:
1、字符相同,则指向左上,并加1
2、字符不同,则指向左边或者上边较大的那个
状态转移方程:

dp[i][j]=dp[i-1][j-1]+1                                 (a[i-1]==b[j-1])

dp[i][j]=max(dp[i-1][j],dp[i][j-1] )              (a[i-1]!=b[j-1])

lcs模板

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int dp[1000][1000];
char s1[1000],s2[1000];//定义在外边
int main()
{
while(scanf("%s %s",s1,s2)!=EOF)
{
int i,j;
int l1=strlen(s1);
int l2=strlen(s2);
for(i=0;i<=l1;i++)
dp[0][i]=0;			// xi  yi 第一列  为 0
for(i=0;i<=l2;i++)
dp[i][0];
for(i=1;i<=l1;i++)
{
for(j=1;j<=l2;j++)// 从 1 开始
{
if(s1[i-1]==s2[j-1])
dp[i][j]=dp[i-1][j-1]+1;
else
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
}
}
printf("%d\n",dp[l1][l2]);
}
return 0;
}


会长的回溯法

/*
LCS

BDCABA
ABCBDAB

dp[1][2] = 1
dp[1][1] = 0
dp[2][1] = 0

//子串:连续
//子序列:可以不连续
// LCS

dp[i][j]//第一个字符串在第i个字符前且第二个串在第j个字符前可构成的最长子序列的长度

dp[i][j] = 			0  						i=0 || j=0
dp[i-1][j-1]+1    		 str1[i]==str2[j]
max(dp[i-1][j],dp[i][j-1])	 str1[i]!=str2[j]
*/
#include<cstdio>
#include<cstring>
#include<stack>
#include<algorithm>
using namespace std;
int main()
{
char str1[20];
char str2[20];
while(scanf ("%s %s",str1+1,str2+1)!=EOF)
{
str1[0] = str2[0] = '0';
int l1 = strlen(str1)-1;
int l2 = strlen(str2)-1;
int dp[20][20] = {0};//0  						i=0 || j=0

for (int i = 1 ; i <= l1 ; i++)
{
for (int j = 1 ; j <= l2 ; j++)
{
if (str1[i] == str2[j])//dp[i-1][j-1]+1    		 str1[i]==str2[j]
dp[i][j] = dp[i-1][j-1] + 1;
else
dp[i][j] = max(dp[i-1][j],dp[i][j-1]);//max(dp[i-1][j],dp[i][j-1])	 str1[i]!=str2[j]
}
}

//回溯求LCS
int pos1 = l1;
int pos2 = l2;
stack<char> S;
while (pos1 > 0 && pos2 > 0)
{
if (str1[pos1] == str2[pos2])
{
S.push(str1[pos1]);
pos1--;
pos2--;
}
else if (dp[pos1-1][pos2] > dp[pos1][pos2-1])
pos1--;
else
pos2--;
}
while (!S.empty())
{
printf ("%c%c",S.top(),(S.size() == 1) ? '\n' : ' ');
S.pop();
}
printf ("%d\n",dp[l1][l2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: