您的位置:首页 > 其它

HDU 1325 Is It A Tree? ( 有向图判断环

2017-08-08 01:21 465 查看

Is It A Tree?

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.







In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line
Case k is a tree." or the line
Case k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1


Sample Output

Case 1 is
4000
a tree.
Case 2 is a tree.
Case 3 is not a tree.


题意

有向图判断是否有环

题解:

有向图 度数大于等于2肯定存在环路

AC代码

#include <bits/stdc++.h>
using namespace std;

const int maxn = 10010;
bool vis[maxn];
int indeg[maxn];
int main()
{
int cas = 0;
int a, b;
while(scanf("%d%d", &a, &b),a>=0||b>=0)
{
if(a==0 && b==0)
{
printf("Case %d is a tree.\n", ++cas);
continue;
}
int maxx = 0;
if(a > maxx) maxx = a;
if(b > maxx) maxx = b;
memset(vis, false, sizeof(vis));
memset(indeg, 0, sizeof(indeg));
vis[a] = vis[b] = true;
indeg[b]++;
while(scanf("%d%d", &a, &b), a!=0||b!=0)
{
if(a > maxx) maxx = a;
if(b > maxx) maxx = b;
indeg[b]++;
vis[a] = vis[b] = true;
}
bool flag = true;
int k = 0;
for(int i = 1; i <= maxx; i++)
if(vis[i] && indeg[i] > 1)
{
flag = false;
break;
}
for(int i = 1; i <= maxx; i++)
if(vis[i] && indeg[i] == 0)
k++;
if(!flag || k != 1)
printf("Case %d is not a tree.\n", ++cas);
else
printf("Case %d is a tree.\n", ++cas);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: