您的位置:首页 > 其它

【hdu 1222】Wolf and Rabbit

2017-08-07 18:12 453 查看


Wolf and Rabbit

 

There is a hill with n holes around. The holes are signed from 0 to n-1. 



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are
signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes. 

InputThe input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648). 

OutputFor each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line. 

Sample Input
2
1 2
2 2


Sample Output
NO
YES


题目大意:
有n个洞,第一个是0,最后一个是n-1,组成一个环,狼每m个洞进去查看一次,如果有安全洞,则输出“yes”,否则输出“no"。

题解:本题的重点就在于判断n,m是否互质,即最大公约数是否是1,如果是,则输出“no”,反之“yes”。

代码:
#include<cstdio>
int main()
{
int gcd(int a,int b);
int T;
long long m,n;
scanf("%d",&T);
while(T--)
{
scanf("%lld%lld",&m,&n);
if(gcd(m,n)==1)  printf("NO\n");
else printf("YES\n");
}
return 0;
}
int gcd(int a,int b)
{
if(b==0) return a;
return gcd(b,a%b);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: