您的位置:首页 > 其它

poj1988_并查集

2017-08-07 16:16 295 查看
Cube Stacking

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:

moves and counts.

* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.

* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a ‘M’ for a move operation or a ‘C’ for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6

M 1 6

C 1

M 2 4

M 2 6

C 3

C 4

Sample Output

1

0

2

Source

USACO 2004 U S Open

记录容器中多少个元素,容器头部多少个元素,减一下;

#include<cstdio>
const int N=30030;
int p
,cnt
,top
;
int Find(int x)
{
int t;
if(p[x]!=x)
{
t=p[x];
p[x]=Find(p[x]);
top[x]+=top[t];
}
return p[x];
}
void init(int x,int y)
{
int tx=Find(x);
int ty=Find(y);
if(tx!=ty)
{
p[ty]=tx;
top[ty]=cnt[tx];
cnt[tx]+=cnt[ty];
}

}
int main()
{
int t,i,j;
for(i=0;i<N;i++)
{
p[i]=i;
cnt[i]=1;
top[i]=0;
}
scanf("%d",&t);
while(t--)
{
char str[10];
int a,b;
scanf("%s",str);
if(str[0]=='M')
{
scanf("%d%d",&a,&b);
init(a,b);
}
else
{
scanf("%d",&a);
int tt=Find(a);
printf("%d\n",cnt[tt]-top[a]-1);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj