您的位置:首页 > 其它

POJ3276 Face The Right Way

2017-08-07 15:10 405 查看
Face The Right Way

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 5270 Accepted: 2458

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same location as before, but ends up facing the opposite direction. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer: N

Lines 2..N+1: Line i+1 contains a single character, F or B, indicating whether cow i is facing forward or backward.

Output

Line 1: Two space-separated integers: K and M

Sample Input

7

B

B

F

B

F

B

B

Sample Output

3 3

Hint

For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

Source

USACO 2007 March Gold

比較常規的反轉問題

時間卡的比較死,需要好好優化

AC代碼:

#include<iostream>
#include<cstring>
#include<string>
using namespace std;
int n;
int a[5005];
int b[5005];
int mac;
int MIN;
int K;
int check(int i)
{
if (i >= n)
return 0;
return 1;
}
void solve()
{
memset(b, 0, sizeof(b));
int time = 0;
int sum = 0;
for (int i = 0; i <= n - mac; i++)
{
if ((a[i]+sum)%2)
{
time++;
b[i] = 1;
}
sum += b[i];
if (i - mac + 1 >= 0)
{
sum -= b[i - mac + 1];
}
}
bool flag = 1;
for (int i = n - mac + 1; i<n; i++)
{

if ((a[i] + sum) % 2 != 0)
{
flag = 0;
break;
}
if (i - mac + 1 >= 0)
{
//保持区间长度
sum -= b[i - mac + 1];
}
}
if (flag)
{
if (time < MIN)
{
MIN = time;
K = mac;
}
}
}
int main()
{
char s;
while (cin >> n)
{
MIN = 0x3f3f3f3f;
for (int i = 0; i < n; i++)
{
cin >> s;
if (s == 'B')//面向后
a[i] = 1;
else         //面向前
a[i] = 0;
}
a
= 0;
for (int i = 1; i <= n; i++)//枚舉mac的能力
{
mac = i;
solve();
}
cout << K << " " << MIN<< endl;

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: