您的位置:首页 > 产品设计 > UI/UE

HDU 1711 Number Sequence(字符串匹配)

2017-08-07 11:19 344 查看

Number Sequence

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 10571 Accepted Submission(s): 4814



[align=left]Problem Description[/align]
Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1]
= b[M]. If there are more than one K exist, output the smallest one.

[align=left]Input[/align]
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which
indicate a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

[align=left]Output[/align]
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

[align=left]Sample Input[/align]

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1


[align=left]Sample Output[/align]

6
-1


#include<iostream>

#include<cstdio>

using namespace std;

const int maxn1=1000010;

const int maxn2=10010;

int n,m;

int a[maxn1];

int b[maxn2];

int next[maxn2];

int main()

{

int kmp (int *a,int *b,int *next);

int t,i;

cin>>t;

while(t--)

{

cin>>n>>m;

for(i=0;i<n;i++)

{scanf("%d",&a[i]);}

for(i=0;i<m;i++)

{scanf("%d",&b[i]);}

int ans=kmp(a,b,next);

cout<<ans<<endl;

}

return 0;

}

//此函数用来求匹配串s串的next数组

void getnext (int *s,int *next)

{

next[0]=next[1]=0;

for (int i=1;i<m;i++)//m为匹配串s的长度

{

int j=next[i];

while (j&&s[i]!=s[j])

j=next[j];

next[i+1]=s[i]==s[j]?

j+1:0;

}

}

//此函数用来求匹配位置的值的函数。匹配不成功返回值-1

int kmp (int *a,int *b,int *next)

{

getnext (b,next);/////////

int j=0;

for (int i=0;i<n;i++)

{/////n为串1的长度

while (j&&a[i]!=b[j])

j=next[j];

if (a[i]==b[j])

j++;

if (j==m)//m为串2的长度

return i-m+2;

}

return -1;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: