您的位置:首页 > 其它

Ignatius and the Princess IV||HDU1029

2017-08-07 10:41 337 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1029

Problem Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?


Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.


Output

For each test case, you have to output only one line which contains the special number you have found.


Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1


Sample Output

3
5
1


题解:让你求出这个特殊的数,只有这个数出现的次数大于(n+1)/2,其实也就是这个数出现的次数最大

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
struct number
{
int times;//出现的次数
int x;//这个数本身
}num[51666];
bool cmp(number x,number y)
{
return x.times>y.times;
}
int main()
{
int n,i,x;
while(~scanf("%d",&n))
{
memset(num,0,sizeof(num));
for(i=0;i<n;i++)
{
scanf("%d",&x);
num[x].times++;
num[x].x=x;
}
sort(num,num+51666,cmp);
printf("%d\n",num[0].x);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: