您的位置:首页 > 编程语言 > Go语言

hdu 5546 Ancient Go 枚举 DFS

2017-08-07 08:33 447 查看


Ancient Go

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)

Total Submission(s): 2498    Accepted Submission(s): 786


Problem Description

Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.

Here is the rules for ancient go they were playing:

⋅The
game is played on a 8×8 cell
board, the chess can be put on the intersection of the board lines, so there are 9×9 different
positions to put the chess.
⋅Yu
Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
⋅The
chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells, this component dies and will be removed from the game board.
⋅When
one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove the dead components.

One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu's
chess.

 

Input

The first line of the input gives the number of test cases, T(1≤T≤100). T test
cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board. ′.′ represents
an empty cell. ′x′ represents
a cell with black chess which owned by Yu Zhou. ′o′ represents
a cell with white chess which owned by Su Lu.

 

Output

For each test case, output one line containing Case #x: y, where x is
the test case number (starting from 1) and y is Can
kill in one move!!!
 if Yu Zhou has a move to kill at least one of Su Lu's components. Can not kill in one move!!! otherwise.

 

Sample Input

2

.......xo
.........
.........
..x......
.xox....x
.o.o...xo
..o......
.....xxxo
....xooo.

......ox.
.......o.
...o.....
..o.o....
...o.....
.........
.......o.
...x.....
........o

 

Sample Output

Case #1: Can kill in one move!!!
Case #2: Can not kill in one move!!!
Hint
In the first test case, Yu Zhou has 4 different ways to kill Su Lu's component.

In the second test case, there is no way to kill Su Lu's component.

 

Source

The 2015 China Collegiate Programming Contest

 

Recommend

wange2014   |   We have carefully selected several similar problems for you:  6079 6078 6077 6076 6075 

 

我也不知道  这叫枚举还是搜索,从o点开始搜,算枚举吧 应不该hdu 5546 Ancient Go 枚举

ac代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;

int t,cnt,flag,cas=0;
int dir[4][2]={1,0,0,1,-1,0,0,-1};
char s[15][15];
int x,y,cnt_node;
int vis[15][15];
struct node{
int x,y;
}nn[105];

void dfs(){

if(flag)
return ;
if(cnt_node >=2)
return ;
if(s[x][y]=='.'){
cnt_node++;
return ;
}
if(s[x][y]=='x')
return ;
for(int i=0;i<4;i++){
if(x+dir[i][0] >=0 && x+dir[i][0] <9 && y+dir[i][1] >=0 && y+dir[i][1] <9 && !vis[x+dir[i][0]][y+dir[i][1]]){
x=x+dir[i][0];
y=y+dir[i][1];
vis[x][y]=1;
dfs();

x=x-dir[i][0];
y=y-dir[i][1];
}
}
}

int main(){

scanf("%d",&t);

flag=0;
while(t--){
getchar();
cnt=0;
for(int i=0;i<9;i++){
scanf("%s",s[i]);
for(int j=0;j<9;j++){
if(s[i][j]=='o'){
nn[cnt].x=i;
nn[cnt].y=j;
cnt++;
}
}
}
flag=0;
for(int i=0;i<cnt;i++){
x=nn[i].x;
y=nn[i].y;
cnt_node=0;
memset(vis,0,sizeof(vis));
vis[x][y]=1;
dfs();
if(cnt_node==1){
flag=1;
break ;
}
}
printf("Case #%d: ",++cas);
if(flag){
printf("Can kill in one move!!!\n");
}
else{
printf("Can not kill in one move!!!\n");
}

/*for(int i=0;i<9;i++){
printf("%s\n",s[i]);
}*/

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: