您的位置:首页 > 其它

(hdu6033)Add More Zero(数学,取对数)

2017-08-06 15:20 323 查看
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1409 Accepted Submission(s): 917

Problem Description

There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so much, which results in his eccentricity that he always ranges integers he would like to use from 1 to 10k (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.

Input

The input contains multiple test cases. Each test case in one line contains only one positive integer m, satisfying 1≤m≤105.

Output

For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

Sample Input

1

64

Sample Output

Case #1: 0

Case #2: 19

Source

2017 Multi-University Training Contest - Team 1

题意:给定m(1<=m<=10^5),求最大的k,使10^k<=2^m-1

分析:2^m m的范围太大,不能直接比较,而求的是10^k<=2^m-1,所以要转化为对数

令10^k=2^m 取对数,k=m*log10(2),k为整数

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
#define mem(a,n) memset(a,n,sizeof(a))
const int N=1e5+5;
typedef long long LL;
int a
;
int main()
{
int m,cas=1;
while(~scanf("%d",&m))
{
printf("Case #%d: ",cas++);
LL ans=m*log10(2);
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数学