您的位置:首页 > 其它

POJ 1797 Heavy Transportation(最大生成树)

2017-08-06 14:46 435 查看
Background

Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed
on which all streets can carry the weight.

Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's
place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers
specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer.
Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5

Sample Output
Scenario #1:
4


            首先根据输入的边建立无向图,在无向图中用Kruskal算法构造最大生成树,当生成树中包含第1个节点和第n个节点时结束,最后加入的边的权值即为答案。

#include <stdio.h>
#include <stdlib.h>
#define MAXV 1000
typedef struct
{
int u;
int v;
int w;
} Edge;
int cmp(const void *a,const void *b)
{
return ((*(Edge *)a).w<(*(Edge *)b).w)?1:-1;
}
int main()
{
int i,j,k,n,m,u1,v1,sn1,sn2,n_t,n_i,count=0;
int vset[MAXV];
Edge E[MAXV*100];//按理说n个顶点的无向图边数最大为n*(n-1)/2
//由于MAXV较大,所以此处数组设置略小
scanf("%d",&n_t);
for(n_i=0; n_i<n_t; ++n_i)
{
k=0;
scanf("%d%d",&n,&m);
for(i=0; i<m; ++i)
{
scanf("%d%d%d",&E[k].u,&E[k].v,&E[k].w);
--E[k].u;
--E[k].v;//题目的编号是从1开始的,此处变为从0开始
++k;
}
qsort(E,m,sizeof(Edge),cmp);//将边按权值由大到小排序
for(i=0; i<n; ++i)
vset[i]=i;
k=1;
j=0;
while(k<n)
{
u1=E[j].u;
v1=E[j].v;
sn1=vset[u1];
sn2=vset[v1];
if(sn1!=sn2)
{
++k;
for(i=0; i<n; ++i)
if(vset[i]==sn2)
vset[i]=sn1;
if(vset[0]==vset[n-1])
break;
}
++j;
}
printf("Scenario #%d:\n%d\n\n",++count,E[j].w);//由于数组E中的边是按顺序排好的
//所以最后加入的边一定是生成树中权值最小的边
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj Kruskal