您的位置:首页 > 其它

poj 3650 The Seven Percent Solution

2017-08-05 21:30 429 查看
The Seven Percent Solution

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7908 Accepted: 5323
Description

Uniform Resource Identifiers (or URIs) are strings like http://icpc.baylor.edu/icpc/, mailto:foo@bar.org, ftp://127.0.0.1/pub/linux, or even just readme.txt that are used to identify a resource, usually on the Internet
or a local computer. Certain characters are reserved within URIs, and if a reserved character is part of an identifier then it must be percent-encoded by replacing it with a percent sign followed by two hexadecimal digits representing the ASCII
code of the character. A table of seven reserved characters and their encodings is shown below. Your job is to write a program that can percent-encode a string of characters.

CharacterEncoding
" " (space)%20
"!" (exclamation point)%21
"$" (dollar sign)%24
"%" (percent sign)%25
"(" (left parenthesis)%28
")" (right parenthesis)%29
"*" (asterisk)%2a
Input

The input consists of one or more strings, each 1–79 characters long and on a line by itself, followed by a line containing only "#" that signals the end of the input. The character "#" is used only as an end-of-input marker and will not appear anywhere
else in the input. A string may contain spaces, but not at the beginning or end of the string, and there will never be two or more consecutive spaces.

Output

For each input string, replace every occurrence of a reserved character in the table above by its percent-encoding, exactly as shown, and output the resulting string on a line by itself. Note that the percent-encoding for an asterisk is %2a (with a lowercase
"a") rather than %2A (with an uppercase "A").

Sample Input
Happy Joy Joy! http://icpc.baylor.edu/icpc/ plain_vanilla
(**)
?
the 7% solution
#

Sample Output
Happy%20Joy%20Joy%21 http://icpc.baylor.edu/icpc/ plain_vanilla
%28%2a%2a%29
?
the%207%25%20solution

Source

Mid-Central USA 2007
先把输进来的字符串存起来,再根据题意一个一个的遍历输出就可以了。

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
using namespace std;
int n;
int main(){
char a[1111];
while(gets(a))
{
int len=strlen(a);
if(a[0]=='#'&&len==1)
break;
for(int i=0;i<len;i++)
{
if(a[i]==' ')cout<<"%20";
else if(a[i]=='!')cout<<"%21";
else if(a[i]=='$')cout<<"%24";
else if(a[i]=='%')cout<<"%25";
else if(a[i]=='(')cout<<"%28";
else if(a[i]==')')cout<<"%29";
else if(a[i]=='*')cout<<"%2a";
else cout<<a[i];
}
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: